Friday, March 4, 2011

'An unresolvable problem occurred while calculating the upgrade' - Ubuntu Lucid to Maverick Upgrade Error

While upgrading from Lucid (10.04) to Maverick (10.10), most of the time the upgrade is not successful and the error reported is quoted below:

An unresolvable problem occurred while calculating the upgrade:
E:Error, pkgProblemResolver::Resolve generated breaks, this may be
caused by held packages.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the
'update-manager' package and include the files in
/var/log/dist-upgrade/ in the bug report.

This error is being caused due to some broken dependencies on the 'xserver-xorg-video-nouveau' package. You can safely avoid this error by removing the offensive package, upgrade and then re-install the package if required.

You can use Software Center or Synaptic to remove the package. Or follow this command from the Terminal under Applications > Accessories sub-menu:

sudo apt-get remove xserver-xorg-video-nouveau

Links to related Launchpad Bugs:

Related Posts:

Installation , Package Manager , Troubleshooting